Online retailer for industrial customers, commercial customers and public institutions - no sales to private customers
Switch to german languageIndustry-Electronics in English

Products of RCS Audio-Systems


Categories with products from RCS Audio-Systems

  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ Amplifiers ( 45 )
  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ CD-Players ( 4 )
  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ Components/Modules/Accessories ➤ Wallmount ( 3 )
  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ Emergency warning systems ( 40 )
  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ Megaphones ( 11 )
  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ Microphones ( 39 )
  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ Mobile Acoustics ( 13 )
  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ Speakers ➤ Accessories ( 8 )
  • Light & Sound ➤ 100V Electro Acoustic Systems ➤ Tour-Guide-Systems ( 8 )
  • IT-Equipment ➤ 19 Inch-Technology ➤ Accessories/Equipment ➤ Mounting Material ( 2 )
  • Electronics ➤ Energy ➤ Accumulators ➤ Other batteries ( 1 )
  • Electronics ➤ Energy ➤ Chargers ( 3 )
  • Light & Sound ➤ Event equipment ➤ Active-Lecterns ( 1 )
  • Light & Sound ➤ Event equipment ➤ Cases ( 8 )
  • Light & Sound ➤ Event equipment ➤ Headphones ( 1 )
  • Light & Sound ➤ Event equipment ➤ Microphones ( 2 )
  • Light & Sound ➤ Event equipment ➤ Mixers ( 4 )
  • Light & Sound ➤ Event equipment ➤ Power Mixer ( 3 )
  • Light & Sound ➤ Event equipment ➤ Tripods ( 2 )
  • Electronics ➤ Measurement ➤ Resistor Measuring ( 1 )
  • IT-Equipment ➤ Networks ➤ Wireless Networking ➤ Antennas ( 4 )


RCS Audio-Systems RC-110 In-ceiling speaker, 10 W, white, 100 V RCS Audio-Systems LogoRCS Audio-Systems RC-110RCS Audio-Systems RC-110 In-ceiling speaker, 10 W, white, 100 V
The RC-110 is a modern in-ceiling speaker featuring a quick-clamp locking system, setting new standards for ease of installation and security. The speaker can be mounted or removed simply by ...

Lieske Part No.: 363715
Mfg Part No: RC-110
41,80 EUR
RCS Audio-Systems RC-110 plus VAT
≈ £34.99  |  ≈ $46.61
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-110C In-ceiling speaker, 10 W, with 2-way coaxial chassis, white, 100 V RCS Audio-Systems LogoRCS Audio-Systems RC-110CRCS Audio-Systems RC-110C In-ceiling speaker, 10 W, with 2-way coaxial chassis, white, 100 V
CEILING and WALL LOUDSPEAKER 10W, 100V


Ceiling and wall speakers
2-way coaxial driver with broadband integrated woofer and tweeter
Easiest and most advanced Mounting through quick-release ...

Lieske Part No.: 796712
Mfg Part No: RC-110C
60,80 EUR
RCS Audio-Systems RC-110C plus VAT
≈ £50.89  |  ≈ $67.79
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-120C In-ceiling speaker, 20 W, with 2-way coaxial chassis, white, 100 V RCS Audio-Systems LogoRCS Audio-Systems RC-120CRCS Audio-Systems RC-120C In-ceiling speaker, 20 W, with 2-way coaxial chassis, white, 100 V
CEILING and WALL LOUDSPEAKER 20W, 100V Ceiling and wall speakers 2-way coaxial driver with broadband woofer and integrated tweeter simple and modern Mounting through quick-release closure. assembly by ...

Lieske Part No.: 576275
Mfg Part No: RC-120C
64,60 EUR
RCS Audio-Systems RC-120C plus VAT
≈ £54.07  |  ≈ $72.03
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-130C In-ceiling speaker, 30 W, with 2-way coaxial chassis, white, 100 V RCS Audio-Systems LogoRCS Audio-Systems RC-130CRCS Audio-Systems RC-130C In-ceiling speaker, 30 W, with 2-way coaxial chassis, white, 100 V
The RC-130 C built-in speaker offers a modern aesthetic combined with the most advanced mounting technology available: the QUICK-CLAMP mechanism. This system sets new standards in both safety and ease ...

Lieske Part No.: 439427
Mfg Part No: RC-130C
74,10 EUR
RCS Audio-Systems RC-130C plus VAT
≈ £62.02  |  ≈ $82.62
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-210 A Snap-In Mount in-ceiling speaker, 10 W, 100 V RCS Audio-Systems LogoRCS Audio-Systems RC-210 ARCS Audio-Systems RC-210 A Snap-In Mount in-ceiling speaker, 10 W, 100 V
The BW-200 option upgrades the RC-210A built-in loudspeaker with certified ball-impact resistance, making it especially suitable for use in gyms, sports halls, multipurpose facilities, and any ...

Lieske Part No.: 1927682
Mfg Part No: RC-210 A
45,60 EUR
RCS Audio-Systems RC-210 A plus VAT
≈ £38.17  |  ≈ $50.84
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-306 Ceiling-mounted speaker, 15/6 W, 2-piece, metal version RCS Audio-Systems LogoRCS Audio-Systems RC-306RCS Audio-Systems RC-306 Ceiling-mounted speaker, 15/6 W, 2-piece, metal version


Lieske Part No.: 902331
Mfg Part No: RC-306
36,10 EUR
RCS Audio-Systems RC-306 plus VAT
≈ £30.22  |  ≈ $40.25
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-412 AB A/B ceiling-mounted speaker, 2x 15/6 W, 100 V, white RCS Audio-Systems LogoRCS Audio-Systems RC-412AB RC-412 ABRCS Audio-Systems RC-412 AB A/B ceiling-mounted speaker, 2x 15/6 W, 100 V, white
Der RC-412AB von RCS Audio-Systems ist ein A/B-Deckeneinbaulautsprecher mit integrierten 100-V-Übertragern, speziell für die Anwendung in Alarmierungs- und Notrufsystemen konzipiert. Er ermöglicht ...

Lieske Part No.: 537564
Mfg Part No: RC-412 AB
Type: RC-412AB
77,90 EUR
RCS Audio-Systems RC-412 AB plus VAT
≈ £65.20  |  ≈ $86.86
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-420 AB A/B ceiling-mounted speaker, 2x 15/10 W, 100 V, white RCS Audio-Systems LogoRCS Audio-Systems RC-420AB RC-420 ABRCS Audio-Systems RC-420 AB A/B ceiling-mounted speaker, 2x 15/10 W, 100 V, white
Der RC-420 AB von RCS Audio-Systems ist ein A/B-Deckeneinbaulautsprecher für den Einsatz in Alarmierungs- und Informationsanlagen. Er ist speziell für die Einhaltung der Normen DIN EN 50849 und VDE ...

Lieske Part No.: 654255
Mfg Part No: RC-420 AB
Type: RC-420AB
83,60 EUR
RCS Audio-Systems RC-420 AB plus VAT
≈ £69.97  |  ≈ $93.21
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-606 EN EN 54-24 alarm sounder built-in loudspeaker 6 W 100 V with metal fire pot RCS Audio-Systems LogoRCS Audio-Systems RC-606 ENRCS Audio-Systems RC-606 EN EN 54-24 alarm sounder built-in loudspeaker 6 W 100 V with metal fire pot
The RC-606 EN is a high-quality ceiling speaker tested and certified according to EN 54-24:2008 by a notified product certification body. Designed specifically for use in voice alarm systems, it also ...

Lieske Part No.: 1927683
Mfg Part No: RC-606 EN
65,55 EUR
RCS Audio-Systems RC-606 EN plus VAT
≈ £54.87  |  ≈ $73.09
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RC-612 EN EN 54-24 alarm speaker, 2x 6 W, 100 V, with metal fire pot RCS Audio-Systems LogoRCS Audio-Systems RC-612 ENRCS Audio-Systems RC-612 EN EN 54-24 alarm speaker, 2x 6 W, 100 V, with metal fire pot
The RC-612 EN is a professional ceiling speaker certified according to EN 54-24:2008, developed for high-security voice alarm systems. Equipped with two powerful full-range drivers and two 100 V ...

Lieske Part No.: 1927684
Mfg Part No: RC-612 EN
93,10 EUR
RCS Audio-Systems RC-612 EN plus VAT
≈ £77.92  |  ≈ $103.81
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RCA-220 C Active in-ceiling speaker set 2x 20/10 W RCS Audio-Systems LogoRCS Audio-Systems RCA-220C RCA-220 CRCS Audio-Systems RCA-220 C Active in-ceiling speaker set 2x 20/10 W
Der Aktiv-Deckeneinbaulautsprecher vom Typ RCA-220C der Firma RCS Audio-Systems ist ein integriertes Beschallungssystem, bestehend aus zwei Koaxial-Deckeneinbaulautsprechern und einem vormontierten ...

Lieske Part No.: 103075
Mfg Part No: RCA-220 C
Type: RCA-220C
311,60 EUR
RCS Audio-Systems RCA-220 C plus VAT
≈ £260.81  |  ≈ $347.43
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RDR-350 Roll set for RAB series RCS Audio-Systems LogoRCS Audio-Systems RDR-350RCS Audio-Systems RDR-350 Roll set for RAB series
This heavy-duty caster set is the ideal mobility solution for transporting heavy equipment or racks. The set includes four wheels: two rigid fixed casters for straight-line movement and two swivel ...

Lieske Part No.: 631029
Mfg Part No: RDR-350
269,80 EUR
RCS Audio-Systems RDR-350 plus VAT
≈ £225.82  |  ≈ $300.83
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RDR-400 Roll set, for RVP series RCS Audio-Systems LogoRCS Audio-Systems RDR-400RCS Audio-Systems RDR-400 Roll set, for RVP series
Der Schwerlastrollensatz ist die ideale Ergänzung für Schrank- und Rack-Systeme, die mobil und flexibel bleiben sollen – auch bei hoher Belastung. Das Set besteht aus zwei Bockrollen sowie zwei ...

Lieske Part No.: 1927685
Mfg Part No: RDR-400
155,80 EUR
RCS Audio-Systems RDR-400 plus VAT
≈ £130.40  |  ≈ $173.72
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems REF-002 48,3 cm ( 19 inch ) mounting rack, 2 U RCS Audio-Systems LogoRCS Audio-Systems REF-002RCS Audio-Systems REF-002 48,3 cm ( 19 inch ) mounting rack, 2 U
These high-quality 48,3 cm ( 19 inch ) mounting shelves are designed for the flexible integration of various equipment into 19-inch rack systems (DIN 41494 standard). They provide a secure platform ...

Lieske Part No.: 419088
Mfg Part No: REF-002
62,70 EUR
RCS Audio-Systems REF-002 plus VAT
≈ £52.48  |  ≈ $69.91
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems REF-003 48,3 cm ( 19 inch ) mounting rack, 3 U RCS Audio-Systems LogoRCS Audio-Systems REF-003RCS Audio-Systems REF-003 48,3 cm ( 19 inch ) mounting rack, 3 U
48,3 cm ( 19 inch )3U Einstellfach Einstellfach for setting various devices. clamp rails for adjustment in height and depth adjustable. installation depth: 250 mm




Finish: Black Powder Coated ...

Lieske Part No.: 936198
Mfg Part No: REF-003
65,55 EUR
RCS Audio-Systems REF-003 plus VAT
≈ £54.87  |  ≈ $73.09
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RFC-010 48,3 cm ( 19 inch )-rack Flight-Case, 10 U RCS Audio-Systems LogoRCS Audio-Systems RFC-010RCS Audio-Systems RFC-010 48,3 cm ( 19 inch )-rack Flight-Case, 10 U
The RFC-010 is a premium 48,3 cm ( 19 inch ) flight case with 10 rack units (U), designed to meet the highest standards in professional touring, stage, and equipment transport applications. Built ...

Lieske Part No.: 140656
Mfg Part No: RFC-010
578,55 EUR
RCS Audio-Systems RFC-010 plus VAT
≈ £484.25  |  ≈ $645.08
Made to order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RFC-012 48,3 cm ( 19 inch )-rack 'Flight-Case' (12 U) RCS Audio-Systems LogoRCS Audio-Systems RFC-012RCS Audio-Systems RFC-012 48,3 cm ( 19 inch )-rack 'Flight-Case' (12 U)
48,3 cm ( 19 inch )FLIGHT CASE RACK body made ​​of plastic, kreuzschichtverleimtem multi-plywood. edge protection made ​​of durable, full perimeter aluminum ...

Lieske Part No.: 634930
Mfg Part No: RFC-012
598,50 EUR
RCS Audio-Systems RFC-012 plus VAT
≈ £500.94  |  ≈ $667.33
Made to order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RFC-015 48,3 cm ( 19 inch )-rack Flight-Case, 15 U RCS Audio-Systems LogoRCS Audio-Systems RFC-015RCS Audio-Systems RFC-015 48,3 cm ( 19 inch )-rack Flight-Case, 15 U
Der RCS Audio-Systems RFC-015 ist ein 48,3 cm ( 19 inch )-Rack im Flight-Case-Design mit einer Höhe von 15 Höheneinheiten (HE). Es ist für den professionellen Einsatz in der Veranstaltungstechnik ...

Lieske Part No.: 552982
Mfg Part No: RFC-015
625,10 EUR
RCS Audio-Systems RFC-015 plus VAT
≈ £523.21  |  ≈ $696.99
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RFC-020 48,3 cm ( 19 inch )-rack Flight-Case, 20 U RCS Audio-Systems LogoRCS Audio-Systems RFC-020RCS Audio-Systems RFC-020 48,3 cm ( 19 inch )-rack Flight-Case, 20 U
The RFC-020 is a professional 19˝ flight case rack, designed for the demanding needs of live touring, stage environments, and safe transport via freight or air shipping. Built to international 19˝ ...

Lieske Part No.: 233665
Mfg Part No: RFC-020
707,75 EUR
RCS Audio-Systems RFC-020 plus VAT
≈ £592.39  |  ≈ $789.14
Made to order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RFF-200 Fan array for RAB-series enclosures RCS Audio-Systems LogoRCS Audio-Systems RFF-200RCS Audio-Systems RFF-200 Fan array for RAB-series enclosures
Description
The 2-fan panel developed specifically for this cabinet is mounted on the rear of the cabinet. The power is supplied via the 230 V mains.

Lieske Part No.: 951595
Mfg Part No: RFF-200
440,80 EUR
RCS Audio-Systems RFF-200 plus VAT
≈ £368.95  |  ≈ $491.49
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RFF-300 Fan array, 3-way, for RSS series RCS Audio-Systems LogoRCS Audio-Systems RFF-300RCS Audio-Systems RFF-300 Fan array, 3-way, for RSS series
Product Description (English):
The specially designed 3-fan ventilation unit is engineered for effective cooling of network cabinets and IT enclosures. It is mounted in place of the top bracket at the ...

Lieske Part No.: 197003
Mfg Part No: RFF-300
522,50 EUR
RCS Audio-Systems RFF-300 plus VAT
≈ £437.33  |  ≈ $582.59
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RFF-402 A 48,3 cm ( 19 inch ) ventilation unit, 4 U, for RVP series RCS Audio-Systems LogoRCS Audio-Systems RFF-402 ARCS Audio-Systems RFF-402 A 48,3 cm ( 19 inch ) ventilation unit, 4 U, for RVP series
This dual-fan module is specifically designed to ensure efficient ventilation within technical or 19″ cabinets. It is mounted directly onto the rack rails of the cabinet, providing effective airflow ...

Lieske Part No.: 1927686
Mfg Part No: RFF-402 A
359,10 EUR
RCS Audio-Systems RFF-402 A plus VAT
≈ £300.57  |  ≈ $400.40
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RGL-400 Slide rails, 1 pair, for RVP series RCS Audio-Systems LogoRCS Audio-Systems RGL-400RCS Audio-Systems RGL-400 Slide rails, 1 pair, for RVP series
For the secure and stable installation of heavy 19″ rack-mounted devices, the use of sliding rails is highly recommended. They provide mechanical reinforcement and make it easier to slide devices in ...

Lieske Part No.: 1927687
Mfg Part No: RGL-400
39,90 EUR
RCS Audio-Systems RGL-400 plus VAT
≈ £33.40  |  ≈ $44.49
On order · Delivery time approx. 20 workdaysinfo_outline
RCS Audio-Systems RGL-525 Slide rails, 1 pair, for RAB series RCS Audio-Systems LogoRCS Audio-Systems RGL-525RCS Audio-Systems RGL-525 Slide rails, 1 pair, for RAB series
The RGL-525 sliding rails are specially designed for the RAB series rack enclosures and provide safe, stable, and convenient support for heavy 19″ equipment. They reduce mechanical stress on front ...

Lieske Part No.: 1927688
Mfg Part No: RGL-525
45,60 EUR
RCS Audio-Systems RGL-525 plus VAT
≈ £38.17  |  ≈ $50.84
On order · Delivery time approx. 20 workdaysinfo_outline
1 2 3 4 5 6 7 8 9 11 13 14 15 16 17 19 21 22 23 24 25 26 27
Searching
Search is performed.
Please be patient ...
Fehlende Felder
Close

We use cookies. Some are required to run the shop (e.g. shopping cart and login), others help us improve it (Google Analytics). Statistics cookies are only used with your consent. See our privacy policy for details.