Zyxel Switch 8x GE GS1920-8HPV2 PoE+ Managed
|
167,67 EUR 170,65 EUR |
|
|
( 199,53 EUR incl. VAT ) ≈ £142.18 | ≈ $187.96 plus delivery charges: 53,00 € |
|
| Delivery time from supplier's stock (ca.) 6 workdaysinfo_outline | |
| In Stock: >25 pieces | |
| End-Of-Life: | 26. Jul 2026 |
|---|---|
| Datasheet: | file_download Download |
| Lieske Part No.: | 1499179 |
| Mfg Part No: | GS1920-8HPV2-EU0101F |
| UPC/EAN: | 4718937602230 |
| Weight: | 2.677 kg |
Product information for Zyxel GS1920-8HPV2-EU0101F:
| Certificates | |
| Certification | RoHS |
| Data transmission | |
| Switching capacity | 20 Gbit/s |
| Forwarding rate | 15 Mpps |
| MAC address table | 16000 entries |
| Packet buffer memory | 1.5 MB |
| Design | |
| Product colour | Black |
| Safety | LVD, BSMI |
| Electromagnetic compatibility | FCC 15 A, CE A, BSMI EMC |
| Rack mounting | |
| LED indicators | |
| Wall mountable | |
| Logistics data | |
| Harmonized System (HS) code | 85176990 |
| Management features | |
| Switch type | Managed |
| MIB support | RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293 |
| Quality of Service (QoS) support | |
| ARP inspection | |
| System event log | |
| Multicast features | |
| Multicast support | |
| Network | |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
| Copper ethernet cabling technology | 100BASE-TX, 1000BASE-T |
| Virtual LAN features | Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN |
| 10G support | |
| Flow control support | |
| Rate limiting | |
| Spanning tree protocol | |
| VLAN support | |
| Operational conditions | |
| Operating temperature (T-T) | 0 - 50 °C |
| Storage temperature (T-T) | -40 - 70 °C |
| Operating relative humidity (H-H) | 10 - 95% |
| Storage relative humidity (H-H) | 10 - 95% |
| Heat dissipation | 551.74 BTU/h |
| Optical fiber | |
| Fiber ethernet cabling technology | 1000BASE-X |
| Packaging content | |
| Cables included | AC |
| Packaging data | |
| Package width | 375 mm |
| Package depth | 235 mm |
| Package height | 61 mm |
| Package weight | 2.73 kg |
| Performance | |
| Internal memory | 256 MB |
| Flash memory | 32 MB |
| Noise level | 0 dB |
| Mean time between failures (MTBF) | 513985 h |
| Ports & interfaces | |
| Basic switching RJ-45 Ethernet ports quantity | 8 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Combo SFP ports quantity | 2 |
| Fiber optic connector | SFP |
| Power | |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50 - 60 Hz |
| Power consumption (max) | 161.8 W |
| Power over Ethernet (PoE) | |
| Power over Ethernet (PoE) ports quantity | 8 |
| Total Power over Ethernet (PoE) budget | 130 W |
| Power over Ethernet (PoE) | |
| Security | |
| DHCP features | DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client |
| Security algorithms | 802.1x RADIUS, SNMP, SNMPv3 |
| Authentication | Guest VLAN, Port-based authentication |
| Authentication type | IEEE 802.1x, RADIUS |
| Queue scheduling algorithms | SPQ, WFQ, Weighted Round Robin (WRR) |
| Access Control List (ACL) | |
| IGMP snooping | |
| MAC address filtering | |
| IP-MAC-Port binding | |
| Password protection | |
| CPU defense | |
| Weight & dimensions | |
| Width | 267 mm |
| Depth | 162 mm |
| Height | 44 mm |
| Weight | 1.9 kg |
Questions & answers
What is the delivery time of Zyxel Switch 8x GE GS1920-8HPV2 PoE+ Managed?
The article Zyxel Switch 8x GE GS1920-8HPV2 PoE+ Managed is currently in stock
According to our experience the article is ready for dispatch within 6 working days. The delivery time usually refers to 1 piece. When ordering larger quantities, we can maybe shorten the delivery time. Just send us an inquiry about the desired quantity of Zyxel GS1920-8HPV2-EU0101F to our sales team for an exact delivery time.
How can I buy the item at a lower price?
We offer you Zyxel Switch 8x GE GS1920-8HPV2 PoE+ Managed always at the best possible price. We can give you a discount of 2% on Zyxel Switch 8x GE GS1920-8HPV2 PoE+ Managed if you choose payment in advance on ordering.
We also offer individual prices for your needs. You can get an offer by using the form Wholesale Inquiry.
Fitting accessory for Zyxel Switch 8x GE GS1920-8HPV2 PoE+ Managed
|
ALLNET ALL-SG8428M / 24 Port Gigabit Copper + 4x SFP smart-managed, fanless
Kostengünstiger 24 Port Managed Gigabit Layer 2 Switch + 4x SFP miniGBIC Slot Without cooling fan for desktop and 19 rack installation Highlights: 24 Port Gigabit non-blocking switch architecture ...Lieske Part No.: 225949 Mfg Part No: ALL-SG8428M |
141,55 EUR
![]() ≈ £120.03 | ≈ $158.68
Made to order · Expected to be available from 18.10.2026info_outline
|
|
ALLNET TP Cat 6 lightning protection
Highlights: Plug and Play installation Zuverlä, FLOWING protection against T, surges of all devices, te with networking switches, routers firewall NoteBook PC / Server Fernsehgerä, te multimedia ...Lieske Part No.: 232880 Mfg Part No: ALL95100 |
18,90 EUR
![]() ≈ £16.03 | ≈ $21.19
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4753 Mini GBIC modules, 1000Mbps, SX / LC
1.125G, 1310nm, single mode SFP, 3.3VRange: 40km example, can be used in the Following Following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S E ... Lieske Part No.: 334083 Mfg Part No: ALL4753 |
192,66 EUR
![]() ≈ £163.38 | ≈ $215.97
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL95112 / 12Port overvoltage protection TP / ISDN / ADSL / VDS
Allnet ALL95112 / 12Port overvoltage protection TP / ISDN / ADSL / VDSHighlights: 12 Port 48,3 cm ( 19 inch )1U rackmount Reliable protection against surge voltages of all devices with network ... Lieske Part No.: 340860 Mfg Part No: ALL95112 |
360,81 EUR
![]() ≈ £305.97 | ≈ $404.47
Delivery time from supplier's stock (ca.) 48 workdaysinfo_outline
|
|
Allnet ALL4751 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 1310nm, single mode SFPRange: 10km example, can be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S-E D-Link DES-3250TG, ... Lieske Part No.: 909596 Mfg Part No: ALL4751 |
57,96 EUR
![]() ≈ £49.15 | ≈ $64.97
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4752 Switch module SFP (Mini GBIC) 1000 Mbit, LHX / LC, 20KM
ALLNET Switch module ALL4752 SFP (Mini GBIC) 1000 Mbit, LHX / LC, 20km,for ALLNET / D-Link / Lancom / Zyxel, LC-Conn 1.125G 1310nm singlemode 3.3V, SFP, 20KM reach Lieske Part No.: 939986 Mfg Part No: ALL4752 |
47,50 EUR
![]() ≈ £40.28 | ≈ $53.25
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4750 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 850 nm, multimode, SFPRange: 550m can for example be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S-E D-Link ... Lieske Part No.: 943828 Mfg Part No: ALL4750 |
36,54 EUR
![]() ≈ £30.99 | ≈ $40.96
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4755 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 1550 nm, single mode SFP, 3.3VRange: 70-80km for example, can be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G- 12S-E ... Lieske Part No.: 944422 Mfg Part No: ALL4755 |
151,20 EUR
![]() ≈ £128.22 | ≈ $169.50
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Cyberpower UPS OR650ERM1UGR 48,3 cm ( 19 inch ) 360W Line-Interactive
Dimensions: H44xW433xD235mm, running time: 13/4min (half/full load) (1) USB, (1) serial, (1) remote control port, (4) CEE7 earthing contact socketLine-interactive UPS topology Energy-saving ... Lieske Part No.: 1783692 Mfg Part No: OR650ERM1UGR |
279,30 EUR
![]() ≈ £236.85 | ≈ $313.10
Delivery time from supplier's stock (ca.) 6 workdaysinfo_outline
|
|
Cyberpower UPS OR600ERM1U 48,3 cm ( 19 inch ) 360W Line-Interactive
Dimensions: H44xW433xD235mm, running time: 13/4min (half/full load) (1) USB, (1) serial, (1) remote control port, (6) IEC C13 cold device socketline-interactive UPS topology energy-saving technology ... Lieske Part No.: 1783693 Mfg Part No: OR600ERM1U |
279,30 EUR
![]() ≈ £236.85 | ≈ $313.10
Delivery time from supplier's stock (ca.) 5 workdaysinfo_outline
|


















