Zyxel Switch 48x GE GS1920-48V2 44xRJ45 4xCombo Managed
|
326,76 EUR |
|
|
( 388,84 EUR incl. VAT ) ≈ £275.13 | ≈ $366.95 plus delivery charges: 53,00 € |
|
| Delivery time from supplier's stock (ca.) 6 workdaysinfo_outline | |
| In Stock: >10 pieces | |
| End-Of-Life: | 26. Jul 2026 |
|---|---|
| Datasheet: | file_download Download |
| Lieske Part No.: | 1479551 |
| Mfg Part No: | GS1920-48V2-EU0101F |
| UPC/EAN: | 4718937601899 |
| Weight: | 4.064 kg |
Product information for Zyxel GS1920-48V2-EU0101F:
| Certificates | |
| Certification | RoHS |
| Data transmission | |
| Switching capacity | 100 Gbit/s |
| Forwarding rate | 74 Mpps |
| MAC address table | 16000 entries |
| Packet buffer memory | 1.5 MB |
| Design | |
| Product colour | Black |
| Safety | LVD, BSMI |
| Electromagnetic compatibility | FCC 15 A, CE A, BSMI EMC |
| Rack mounting | |
| LED indicators | |
| Logistics data | |
| Harmonized System (HS) code | 85176990 |
| Management features | |
| Switch type | Managed |
| MIB support | RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293 |
| Quality of Service (QoS) support | |
| ARP inspection | |
| System event log | |
| Multicast features | |
| Multicast support | |
| Network | |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
| Copper ethernet cabling technology | 100BASE-TX, 1000BASE-T |
| Virtual LAN features | Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN |
| 10G support | |
| Flow control support | |
| Rate limiting | |
| Spanning tree protocol | |
| VLAN support | |
| Operational conditions | |
| Operating temperature (T-T) | 0 - 50 °C |
| Storage temperature (T-T) | -40 - 70 °C |
| Operating relative humidity (H-H) | 10 - 95% |
| Storage relative humidity (H-H) | 10 - 95% |
| Heat dissipation | 125.83 BTU/h |
| Optical fiber | |
| Fiber ethernet cabling technology | 1000BASE-X |
| Packaging content | |
| Cables included | AC |
| Rack mount kit | |
| Packaging data | |
| Package width | 496 mm |
| Package depth | 289 mm |
| Package height | 90 mm |
| Package weight | 3.97 kg |
| Performance | |
| Internal memory | 256 MB |
| Flash memory | 32 MB |
| Noise level | 26 dB |
| Mean time between failures (MTBF) | 672235 h |
| Ports & interfaces | |
| Basic switching RJ-45 Ethernet ports quantity | 44 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Combo SFP ports quantity | 4 |
| SFP module slots quantity | 2 |
| Fiber optic connector | SFP |
| Power | |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50 - 60 Hz |
| Power consumption (max) | 36.9 W |
| Power over Ethernet (PoE) | |
| Power over Ethernet (PoE) | |
| Security | |
| DHCP features | DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client |
| Security algorithms | 802.1x RADIUS, SNMP, SNMPv3 |
| Authentication | Guest VLAN, Port-based authentication |
| Authentication type | IEEE 802.1x, RADIUS |
| Queue scheduling algorithms | SPQ, WFQ, Weighted Round Robin (WRR) |
| Access Control List (ACL) | |
| IGMP snooping | |
| MAC address filtering | |
| IP-MAC-Port binding | |
| Password protection | |
| CPU defense | |
| Weight & dimensions | |
| Width | 440 mm |
| Depth | 220 mm |
| Height | 44.5 mm |
| Weight | 2.8 kg |
Questions & answers
What is the delivery time of Zyxel Switch 48x GE GS1920-48V2 44xRJ45 4xCombo Managed?
The article Zyxel Switch 48x GE GS1920-48V2 44xRJ45 4xCombo Managed is currently in stock
According to our experience the article is ready for dispatch within 6 working days. The delivery time usually refers to 1 piece. When ordering larger quantities, we can maybe shorten the delivery time. Just send us an inquiry about the desired quantity of Zyxel GS1920-48V2-EU0101F to our sales team for an exact delivery time.
How can I buy the item at a lower price?
We offer you Zyxel Switch 48x GE GS1920-48V2 44xRJ45 4xCombo Managed always at the best possible price. We can give you a discount of 2% on Zyxel Switch 48x GE GS1920-48V2 44xRJ45 4xCombo Managed if you choose payment in advance on ordering.
We also offer individual prices for your needs. You can get an offer by using the form Wholesale Inquiry.
Fitting accessory for Zyxel Switch 48x GE GS1920-48V2 44xRJ45 4xCombo Managed
|
Allnet ALL95100 TP Cat 6 surge and lightning protection surge protector
Highlights: Plug and Play installation Zuverlä, FLOWING protection against T, surges of all devices, te with networking switches, routers firewall NoteBook PC / Server Fernsehgerä, te multimedia ...Lieske Part No.: 232880 Mfg Part No: ALL95100 |
18,90 EUR
![]() ≈ £15.91 | ≈ $21.22
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4753 Mini GBIC modules, 1000Mbps, SX / LC
1.125G, 1310nm, single mode SFP, 3.3VRange: 40km example, can be used in the Following Following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S E ... Lieske Part No.: 334083 Mfg Part No: ALL4753 |
192,66 EUR
![]() ≈ £162.22 | ≈ $216.36
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL95112 / 12Port overvoltage protection TP / ISDN / ADSL / VDS
Allnet ALL95112 / 12Port overvoltage protection TP / ISDN / ADSL / VDSHighlights: 12 Port 48,3 cm ( 19 inch )1U rackmount Reliable protection against surge voltages of all devices with network ... Lieske Part No.: 340860 Mfg Part No: ALL95112 |
350,58 EUR 360,81 EUR
![]() ≈ £295.19 | ≈ $393.70
Delivery time from supplier's stock (ca.) 48 workdaysinfo_outline
|
|
Allnet ALL4751 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 1310nm, single mode SFPRange: 10km example, can be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S-E D-Link DES-3250TG, ... Lieske Part No.: 909596 Mfg Part No: ALL4751 |
57,96 EUR
![]() ≈ £48.80 | ≈ $65.09
Delivery time from supplier's stock (ca.) 19 workdaysinfo_outline
|
|
Allnet ALL4752 Switch module SFP (Mini GBIC) 1000 Mbit, LHX / LC, 20KM
ALLNET Switch module ALL4752 SFP (Mini GBIC) 1000 Mbit, LHX / LC, 20km,for ALLNET / D-Link / Lancom / Zyxel, LC-Conn 1.125G 1310nm singlemode 3.3V, SFP, 20KM reach Lieske Part No.: 939986 Mfg Part No: ALL4752 |
-39% 28,75 EUR 47,50 EUR
![]() ≈ £24.21 | ≈ $32.29
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4750 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 850 nm, multimode, SFPRange: 550m can for example be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S-E D-Link ... Lieske Part No.: 943828 Mfg Part No: ALL4750 |
36,54 EUR
![]() ≈ £30.77 | ≈ $41.03
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4755 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 1550 nm, single mode SFP, 3.3VRange: 70-80km for example, can be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G- 12S-E ... Lieske Part No.: 944422 Mfg Part No: ALL4755 |
151,20 EUR
![]() ≈ £127.31 | ≈ $169.80
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL-SG8452M Switch smart managed 48 Port Gigabit / 48x LAN / 4x SFP / fanless / 48,3 cm ( 19 inch ) /
Kostengünstiger 48 Port Managed Gigabit Layer-2 Switch + 4x SFP MiniGbic Slots LÜFTERLOS für Desktop und 48,3 cm ( 19 inch ) Rackinstallation Highlights: 48 Port Gigabit non-blocking Switch ...Lieske Part No.: 1159727 Mfg Part No: ALL-SG8452M |
-11% 302,40 EUR 339,05 EUR
![]() ≈ £254.62 | ≈ $339.60
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
















