Zyxel Switch 24x GE GS1900-24 V2
|
112,67 EUR |
|
|
( 134,08 EUR incl. VAT ) ≈ £95.54 | ≈ $126.30 plus delivery charges: 53,00 € |
|
| Delivery time from supplier's stock (ca.) 5 workdaysinfo_outline | |
| In Stock: >5 pieces | |
| Datasheet: | file_download Download |
|---|---|
| Lieske Part No.: | 1928882 |
| Mfg Part No: | GS1900-24-EU0102F |
| UPC/EAN: | 4718937621231 |
| Weight: | 2.66 kg |
Product information for Zyxel GS1900-24-EU0102F:
Highlights
- Smart Managed Ethernet Switch with GbE Uplink
- 24x Gigabit Ethernet port
- 2x Gigabit SFP port
- Fanless design for silent operation
- Simple browser-based switch management, with quick and easy setup wizard
- Switch capacity: 52 Gbit/s
- Desktop and Rack mounting possible
- Switch
- ear category (ElektroG): relevant, Category 6: small IT and telecommunications technology devices, Small IT and telecommunications technology devices B2C
- Switch type: Access
- Switching capacity: 52 GBit/s (Gbps)
- WEEE: 40153029
- Total number of copper ports: 24
- Total number of fiber optic ports: 2
- Bandwidth: 10/100/1000 MBit/s
- Main port type: Copper
- Number of RJ45 ports (1G): 24
- Number of SFP ports (1G): 2
- Switch manageable: Yes
- Mounting type: desktop, 48,3 cm ( 19 inch ) rack mount
- IGMP
- Power supply: integrated
- Color: Black
- Height: 44 mm
- Length/depth: 131 mm
- Width: 440 mm
- Weight: 2.09 kg
- Zyxel GS1900-24 V2 24 Port GbE L2 Smart Switch
- Power cable
- Rack mount kit
Product type
Specifications
Shipping
Connections
Functions
Power supply
Basic features
Scope of delivery
| Certificates | |
| Certification | EMC ■ CE, FCC, C-Tick, Class A (GS1900-24/24EP/24HPv2/48/ 48HPv2) ■ CE, FCC, C-Tick, Class B (GS1900-8/8HP/10HP/16/24E) ■ BSMI CNS13438 • Safety ■ LVD EN60950-1 ■ BSMI CNS14336-1 ■ CB IEC60950-1 (GS1900-8HP/10HP/16/24E/24) • RoHS compliant |
| Data transmission | |
| Switching capacity | 52 Gbit/s |
| Forwarding rate | 39 Mpps |
| MAC address table | 8000 entries |
| Jumbo frames | 9000 |
| Packet buffer memory | 0.525 MB |
| Store-and-forward | |
| Jumbo frames support | |
| Design | |
| Form factor | 1U |
| Product colour | Black |
| Rack mounting | |
| Stackable | |
| Reset button | |
| LED indicators | |
| Logistics data | |
| Harmonized System (HS) code | 85176990 |
| Management features | |
| Switch type | Managed |
| Switch layer | L2 |
| MIB support | RFC 1213 MIB II, RFC 2819 RMON (group 1, 2, 3, 9), RFC 1215, RFC 1493 |
| Quality of Service (QoS) support | |
| Web-based management | |
| System event log | |
| Network | |
| Networking standards | IEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x |
| Ethernet LAN data rates | 10,100,1000 Mbit/s |
| Virtual LAN features | Tagged VLAN, VLAN Identifier ( VLAN ID), Voice VLAN |
| 10G support | |
| Port mirroring | |
| Full duplex | |
| Flow control support | |
| Link aggregation | |
| Spanning tree protocol | |
| MAC address auto-learning supported | |
| VLAN support | |
| Operational conditions | |
| Operating temperature (T-T) | 0 - 50 °C |
| Storage temperature (T-T) | -40 - 70 °C |
| Operating relative humidity (H-H) | 10 - 95% |
| Storage relative humidity (H-H) | 10 - 95% |
| Heat dissipation | 55 BTU/h |
| Packaging content | |
| Cables included | AC |
| Rack mount kit | |
| Packaging data | |
| Package type | Box |
| Package width | 561 mm |
| Package depth | 217 mm |
| Package height | 82 mm |
| Package weight | 2.85 kg |
| Performance | |
| Mean time between failures (MTBF) | 432.673 h |
| Ports & interfaces | |
| Basic switching RJ-45 Ethernet ports quantity | 24 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| SFP module slots quantity | 2 |
| Power connector | AC-in jack |
| Power | |
| Power source | AC |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50 - 60 Hz |
| Power consumption (max) | 16 W |
| Power supply included | |
| Power over Ethernet (PoE) | |
| Power over Ethernet (PoE) | |
| Security | |
| DHCP features | DHCP client |
| Security algorithms | 802.1x RADIUS |
| Authentication type | RADIUS, TACACS+ |
| IGMP snooping | |
| MAC address filtering | |
| Static port security | |
| SSH/SSL support | |
| Password protection | |
| Weight & dimensions | |
| Width | 440 mm |
| Depth | 131 mm |
| Height | 44 mm |
| Weight | 2.09 kg |
Questions & answers
What is the delivery time of Zyxel Switch 24x GE GS1900-24 V2?
The article Zyxel Switch 24x GE GS1900-24 V2 is currently in stock
According to our experience the article is ready for dispatch within 5 working days. The delivery time usually refers to 1 piece. When ordering larger quantities, we can maybe shorten the delivery time. Just send us an inquiry about the desired quantity of Zyxel GS1900-24-EU0102F to our sales team for an exact delivery time.
How can I buy the item at a lower price?
We offer you Zyxel Switch 24x GE GS1900-24 V2 always at the best possible price. We can give you a discount of 2% on Zyxel Switch 24x GE GS1900-24 V2 if you choose payment in advance on ordering.
We also offer individual prices for your needs. You can get an offer by using the form Wholesale Inquiry.
Fitting accessory for Zyxel Switch 24x GE GS1900-24 V2
|
ALLNET ALL-SG8428M / 24 Port Gigabit Copper + 4x SFP smart-managed, fanless
Kostengünstiger 24 Port Managed Gigabit Layer 2 Switch + 4x SFP miniGBIC Slot Without cooling fan for desktop and 19 rack installation Highlights: 24 Port Gigabit non-blocking switch architecture ...Lieske Part No.: 225949 Mfg Part No: ALL-SG8428M |
141,55 EUR
![]() ≈ £120.03 | ≈ $158.68
Made to order · Expected to be available from 18.10.2026info_outline
|
|
Allnet ALL4753 Mini GBIC modules, 1000Mbps, SX / LC
1.125G, 1310nm, single mode SFP, 3.3VRange: 40km example, can be used in the Following Following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S E ... Lieske Part No.: 334083 Mfg Part No: ALL4753 |
192,66 EUR
![]() ≈ £163.38 | ≈ $215.97
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4751 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 1310nm, single mode SFPRange: 10km example, can be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S-E D-Link DES-3250TG, ... Lieske Part No.: 909596 Mfg Part No: ALL4751 |
57,96 EUR
![]() ≈ £49.15 | ≈ $64.97
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4752 Switch module SFP (Mini GBIC) 1000 Mbit, LHX / LC, 20KM
ALLNET Switch module ALL4752 SFP (Mini GBIC) 1000 Mbit, LHX / LC, 20km,for ALLNET / D-Link / Lancom / Zyxel, LC-Conn 1.125G 1310nm singlemode 3.3V, SFP, 20KM reach Lieske Part No.: 939986 Mfg Part No: ALL4752 |
47,50 EUR
![]() ≈ £40.28 | ≈ $53.25
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4750 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 850 nm, multimode, SFPRange: 550m can for example be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G-12S-E D-Link ... Lieske Part No.: 943828 Mfg Part No: ALL4750 |
36,54 EUR
![]() ≈ £30.99 | ≈ $40.96
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|
|
Allnet ALL4755 Mini GBIC Module, 1000Mbps, SX / LC
1.125G, 1550 nm, single mode SFP, 3.3VRange: 70-80km for example, can be used in the following devices: 3Com Switch 8800, 7750, 5500, 5500G Cisco Catalyst 3560-24PS-E, 3560G-24TS-E, 3750G- 12S-E ... Lieske Part No.: 944422 Mfg Part No: ALL4755 |
151,20 EUR
![]() ≈ £128.22 | ≈ $169.50
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
|













