Online retailer for industrial customers, commercial customers and public institutions - no sales to private customers
Switch to german languageIndustry-Electronics in English
Allied Telesis Logo

Allied Telesis AT-FS750/20-50 L2 WS FE 16 + 4 COMBO GE PS

Your rating:
Average rating
product review for Allied Telesis AT-FS750/20-50 L2 WS FE 16 + 4 COMBO GE PS
( 4 / 5 ) 1 ratings
Allied Telesis AT-FS750/20-50
This image may differ from the desired article.
114,13 EUR
( 135,81 EUR incl. VAT )
≈ £96.10  |  ≈ $128.17
plus delivery charges: 53,00 €
Made to order · Delivery time approx. 20 workdaysinfo_outline
1x Allied Telesis AT-FS750/20-50 L2 WS FE 16 + 4 COMBO GE PS
End-Of-Life: 18. Dec 2025
Datasheet:file_download Download
Lieske Part No.:443749
Mfg Part No: AT-FS750/20-50
UPC/EAN: 0767035203898
Weight:2.39 kg
Type:CPNT

Product information for Allied Telesis AT-FS750/20-50:

990-004643-50 EN

Data transmission
Switching capacity11.2 Gbit/s
MAC address table8000 entries
Number of queues4
Packet forwarding rate (1 Gbps)1488000 pps
Packet forwarding rate (100 Mbps)148800 pps
Packet forwarding rate (10 Mbps)14880 pps
Jumbo frames supportYes
Design
Form factor1U
Product colourGrey
Rack mountingYes
Logistics data
Harmonized System (HS) code85176990
Management features
Switch typeManaged
MIB supportRFC 1213 MIB-II, RFC 1643 Ethernet MIB, RFC 1493 Bridge MIB, RFC 2131 DHCP client, Private Enterprise MIB
Quality of Service (QoS) supportYes
Web-based managementYes
System event logYes
Multicast features
Number of multicast groups filtered256
Multicast supportYes
Network
Networking standardsIEEE 802.11d, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
Virtual LAN featuresTagged VLAN, Port-based VLAN
10G supportNo
Port mirroringYes
Flow control supportYes
Link aggregationYes
Broadcast storm controlYes
Rate limitingYes
Spanning tree protocolYes
Head-of-line (HOL) blockingYes
Operational conditions
Operating temperature (T-T)0 - 40 °C
Packaging content
Cables includedAC
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity20
Basic switching RJ-45 Ethernet ports typeFast Ethernet (10/100)
Fast Ethernet (copper) ports quantity16
Gigabit Ethernet (copper) ports quantity2
Combo SFP ports quantity2
Power
AC input voltage100 - 240 V
AC input frequency50 - 60 Hz
Power consumption (max)7.6 W
Power over Ethernet (PoE)
Power over Ethernet (PoE)No
Protocols
Management protocolsFTP, HTTP, SNMPv1/v2c/v3, SNTP
Security
DHCP featuresDHCP client
AuthenticationMAC-based authentication
Access Control List (ACL)Yes
IGMP snoopingYes
MAC address filteringYes
Weight & dimensions
Width330 mm
Depth180 mm
Height44 mm
Weight2.2 kg


Please note...
We have listed this article as 'end-of-life', which means that it will only be sold until it is completely sold out ! Please mind that we cannot guarantee you, you will receive the article, although it may be betokened as available. You can find the date from when the article was marked end-of-life to the top.
Product data sheet
Datasheet for Allied Telesis AT-FS750/20-50, EAN: 0767035203898

Questions & answers

What is the delivery time of Allied Telesis AT-FS750/20-50 L2 WS FE 16 + 4 COMBO GE PS?

The article Allied Telesis AT-FS750/20-50 L2 WS FE 16 + 4 COMBO GE PS is currently not in stock and must be ordered on a per-order basis.

According to our experience the article is ready for dispatch within 20 working days. The delivery time usually refers to 1 piece. When ordering larger quantities, we can maybe shorten the delivery time. Just send us an inquiry about the desired quantity of Allied Telesis AT-FS750/20-50 to our sales team for an exact delivery time.

How can I buy the item at a lower price?

We offer you Allied Telesis AT-FS750/20-50 L2 WS FE 16 + 4 COMBO GE PS always at the best possible price. We can give you a discount of 2% on Allied Telesis AT-FS750/20-50 L2 WS FE 16 + 4 COMBO GE PS if you choose payment in advance on ordering.

We also offer individual prices for your needs. You can get an offer by using the form Wholesale Inquiry.

 


Searching
Search is performed.
Please be patient ...
Fehlende Felder
Close
Product in the shopcart

The following item has been put into your shopping cart by our system:

1x Allied Telesis CPNT (AT-FS750/20-50)
Allied Telesis AT-FS750/20-50 L2 WS FE 16 + 4 COMBO GE PS
114,13 EUR
Sum of all articles in cart
plus VAT
You can continue shopping and open your cart at any time from the top menu bar or now directly by clicking the button.
Enquiry: Allied Telesis CPNT (AT-FS750/20-50)
Company name
Name
Homepage
Street
ZIP-Code City
Country
Telephone
Desired quantity
Comment
9 + 5 =
Data protection notice: The data entered here will only be electronically stored and processed for the purpose of responding to your inquiry in accordance with Art. 6 GDPR para. 1b. The basis for this is our privacy policy.
Name and email address are the only mandatory fields.

We use cookies. Some are required to run the shop (e.g. shopping cart and login), others help us improve it (Google Analytics). Statistics cookies are only used with your consent. See our privacy policy for details.