Online retailer for industrial customers, commercial customers and public institutions - no sales to private customers
Switch to german languageIndustry-Electronics in English
Zyxel Logo

Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots

Your rating:
Average rating
product review for Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots
( 5 / 5 ) 1 ratings
Zyxel GS1900-10HP-EU0102FZyxel GS1900-10HP-EU0102FZyxel GS1900-10HP-EU0102FZyxel GS1900-10HP-EU0102FZyxel GS1900-10HP-EU0102FZyxel GS1900-10HP-EU0102FZyxel GS1900-10HP-EU0102FZyxel GS1900-10HP-EU0102F
Zyxel GS1900-10HP-EU0102F
This image may differ from the desired article.
113,04 EUR
( 134,52 EUR incl. VAT )
≈ £95.18  |  ≈ $126.94
plus delivery charges: 53,00 €
Delivery time from supplier's stock (ca.) 7 workdaysinfo_outline
In Stock: >25 pieces
1x Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots
Lieske Part No.:1892462
Mfg Part No: GS1900-10HP-EU0102F
UPC/EAN: 4718937621200
Weight:1.5 kg

Product information for Zyxel GS1900-10HP-EU0102F:

The Zyxel GS1900 Gigabit Switch Series is ideal for small businesses that want to separate traffic on their growing network but don't have a team of IT experts. These switches with their sophisticated functions offer more flexibility and control options. With built-in support for VLANs, enhanced quality of service (QoS), IGMP snooping, link aggregation (LAG), IPv6 and DoS defense, these switches conveniently separate and prioritize wired and wireless traffic while enabling guest network access and providing full control about the bandwidth between the ports. An easy-to-use setup wizard lets you complete these tasks, making setup and management a breeze.

Highlights

  • Smart Managed PoE Ethernet Switch with GbE Uplink
  • 8x Gigabit Ethernet port with PoE 802.3at (PoE budget: 77 W)
  • 2x Gigabit SFP port
  • Fanless design for silent operation
  • Simple browser-based switch management, with quick and easy Setup assistants
  • Switch capacity: 20 Gbit/s
  • Desktop and wall mounting possible
  • Product type

  • Switch
  • ear category (ElektroG): relevant, Category 6: small IT and telecommunications devices, Small IT and telecommunications devices B2C
  • Specifications

  • Switch type: Access
  • Switching capacity: 20 GBit/s (Gbps)
  • Shipping

  • WEEE: 40153029
  • Connections

  • Total number of copper ports: 8
  • Total number of fiber optic ports: 2
  • Total number of PoE ports: 8
  • Bandwidth: 10 /100/1000 MBit/s
  • PoE standard: PoE - 802.3af, PoE+ - 802.3at
  • PoE budget: 77 W
  • Main port type: Copper
  • Number of PoE+ (af/at) ports: 8
  • Number of RJ45 ports (1G) : 8
  • Number of SFP ports (1G): 2
  • Functions

  • Switch manageable: Yes
  • Mounting type: wall, desktop
  • IGMP
  • Power supply

  • Power supply: external
  • Basic features

  • Color: Black
  • Height: 27 mm
  • Length/depth: 104 mm
  • Width: 250 mm
  • Weight: 1.53 kg
  • Box contents

  • Zyxel GS1900-10HP V2 8-Port GbE L2 PoE Smart Switch + 2 SFP
  • Power cable
  • Power supply
  • Wall mounting kit


Certificates
CertificationCE, FCC, RCM, Class A, BSMI CNS 13438, LVD EN 62368-1, BSMI CNS 14336-1
Data transmission
Switching capacity20 Gbit/s
Throughput14.88 Mpps
MAC address table8000 entries
Jumbo frames9000
Design
Product colourBlack
Rack mountingNo
LED indicatorsYes
Wall mountableYes
Management features
Switch typeManaged
Switch layerL2
MIB supportRFC 1213 MIB II, RFC 2819 RMON (group 1, 2, 3, 9), RFC 1215 generic traps, RFC 1493 bridge
Quality of Service (QoS) supportYes
Web-based managementYes
System event logYes
Network
Networking standardsIEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3at, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
Copper ethernet cabling technology10BASE-T, 100BASE-T, 1000BASE-T
Virtual LAN featuresVoice VLAN
10G supportNo
VLAN supportYes
Operational conditions
Operating temperature (T-T)0 - 40 °C
Storage temperature (T-T)-40 - 70 °C
Operating relative humidity (H-H)10 - 95%
Storage relative humidity (H-H)10 - 95%
Packaging content
Cables includedAC
Performance
Mean time between failures (MTBF)800259 h
Ports & interfaces
Basic switching RJ-45 Ethernet ports quantity8
Basic switching RJ-45 Ethernet ports typeGigabit Ethernet (10/100/1000)
SFP module slots quantity2
Console portRJ-45
Power
Power sourceAC
AC input voltage100 - 240 V
AC input frequency50 - 60 Hz
Power consumption (max)95.3 W
Power supply includedYes
Power over Ethernet (PoE)
Power over Ethernet (PoE) ports quantity8
Total Power over Ethernet (PoE) budget77 W
Power over Ethernet (PoE)Yes
Protocols
Management protocolsSNMP, RMON, ICMP, Syslog
Security
DHCP featuresDHCP client
Security algorithms802.1x RADIUS, SSL/TLS
IGMP snoopingYes
MAC address filteringYes
Weight & dimensions
Width250 mm
Depth104 mm
Height27 mm
Weight720 g


Questions & answers

What is the delivery time of Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots?

The article Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots is currently in stock

According to our experience the article is ready for dispatch within 7 working days. The delivery time usually refers to 1 piece. When ordering larger quantities, we can maybe shorten the delivery time. Just send us an inquiry about the desired quantity of Zyxel GS1900-10HP-EU0102F to our sales team for an exact delivery time.

How can I buy the item at a lower price?

We offer you Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots always at the best possible price. We can give you a discount of 2% on Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots if you choose payment in advance on ordering.

We also offer individual prices for your needs. You can get an offer by using the form Wholesale Inquiry.

 


Fitting accessory for Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots

TP(RJ45) POE tester, at/af, endspan/midspan, standard, Synergy 21 Synergy 21 LogoTP(RJ45) POE tester, at/af, endspan/midspan, standard, Synergy 21 .Quickly and Easily test PoE existence of Ethernet network, .Compliant with IEEE 802.3at/af PoE Standard .RJ45 connector, simply plug in the cable .Compact design specially tailored for system ...

Lieske Part No.: 1092748
Mfg Part No: S215281
-14% 7,54 EUR 8,78 EUR
Synergy 21 S215281 plus VAT
≈ £6.35  |  ≈ $8.47
Delivery time from supplier's stock (ca.) 4 workdaysinfo_outline
Cyberpower UPS OR650ERM1UGR 48,3 cm ( 19 inch ) 360W Line-Interactive Cyberpower LogoCyberpower UPS OR650ERM1UGR 48,3 cm ( 19 inch ) 360W Line-Interactive Dimensions: H44xW433xD235mm, running time: 13/4min (half/full load) (1) USB, (1) serial, (1) remote control port, (4) CEE7 earthing contact socket
Line-interactive UPS topology Energy-saving ...

Lieske Part No.: 1783692
Mfg Part No: OR650ERM1UGR
-21% 220,50 EUR 279,30 EUR
CyberPower OR650ERM1UGR plus VAT
≈ £185.66  |  ≈ $247.62
Delivery time from supplier's stock (ca.) 6 workdaysinfo_outline
Cyberpower UPS OR600ERM1U 48,3 cm ( 19 inch ) 360W Line-Interactive Cyberpower LogoCyberpower UPS OR600ERM1U 48,3 cm ( 19 inch ) 360W Line-Interactive Dimensions: H44xW433xD235mm, running time: 13/4min (half/full load) (1) USB, (1) serial, (1) remote control port, (6) IEC C13 cold device socket
line-interactive UPS topology energy-saving technology ...

Lieske Part No.: 1783693
Mfg Part No: OR600ERM1U
221,17 EUR
CyberPower OR600ERM1U plus VAT
≈ £186.23  |  ≈ $248.37
Delivery time from supplier's stock (ca.) 7 workdaysinfo_outline
Searching
Search is performed.
Please be patient ...
Fehlende Felder
Close
Product in the shopcart

The following item has been put into your shopping cart by our system:

1x Zyxel GS1900-10HP-EU0102F Switch 8x GbE POE+ 2x SFP
Zyxel Switch 8x GS1900-10HP GbE L2 POE+ /+2 SFP slots
113,04 EUR
Sum of all articles in cart
plus VAT
You can continue shopping and open your cart at any time from the top menu bar or now directly by clicking the button.
Enquiry: Zyxel GS1900-10HP-EU0102F Switch 8x GbE POE+ 2x SFP
Company name
Name
Homepage
Street
ZIP-Code City
Country
Telephone
Desired quantity
Comment
4 + 6 =
Data protection notice: The data entered here will only be electronically stored and processed for the purpose of responding to your inquiry in accordance with Art. 6 GDPR para. 1b. The basis for this is our privacy policy.
Name and email address are the only mandatory fields.

We use cookies. Some are required to run the shop (e.g. shopping cart and login), others help us improve it (Google Analytics). Statistics cookies are only used with your consent. See our privacy policy for details.